Kawasaki Ninja 250R Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My friend has a 07 ninja 250, and last summer it was running great and then it started running like crap. Once he hits 80 mph his bike loses power and wont go any faster. What could be wrong?

Carbs have been professionally cleaned along with the valves being adjusted. Gas tank has been cleaned, airbox is cleaned, new spark plugs and coils. Compression test was fine.

Also the right cylinder doesnt get warm and theres not exhaust smoke coming from right side muffler.
 

·
Registered
Joined
·
14 Posts
I'm going to take a shot at this because my 2003 ninja was doing the same thing and it took my dealer a few attempts to find the problem. He eventually found the float needles we're not doing thier job. They are supposed to compress and mine wasn't. That helped but still didn't fix it, he then found that both main jets both had some build up and the holes were to small and it wasn't getting the gas it needed. Hope that helps, I'm not a mechanic, but mine did the exact same thing, only mine wouldn't go past 55. Runs like a dream now.
 

·
Registered
Joined
·
1 Posts
I'm going to take a shot at this because my 2003 ninja was doing the same thing and it took my dealer a few attempts to find the problem. He eventually found the float needles we're not doing thier job. They are supposed to compress and mine wasn't. That helped but still didn't fix it, he then found that both main jets both had some build up and the holes were to small and it wasn't getting the gas it needed. Hope that helps, I'm not a mechanic, but mine did the exact same thing, only mine wouldn't go past 55. Runs like a dream now.
Mine seems to be doing that too. I have an 05. It just dies out at around 50 or so when I start slowing down. So is the fix to take the carbs apart, and clean out all jets? I'm a noob so sorry for the possible dumb question.
 
1 - 5 of 5 Posts
Top