Kawasaki Ninja 250R Forum banner
loss
1-5 of 5 Results
  1. Technical
    So this will probably end of in a large wall of text so please bear with me. About a month ago I got my 2009 Ninja 250R out from storage and brought it down to my university which is about a 3 hour ride. Everything went fine and she started right up after I got her out of storage. Well that...
  2. Technical
    hi guys... I own a 2011 ninja 250r. My ride had covered about 8k kms. The thing is my ride does about only 160Kmphr which is quiet less compared to other bikes. As i had a problem with my clutch cables and plates, i had changed both in my last service. As in my state i don't get the octane-95...
  3. Technical
    I rejetted my carbs and installed pods, drilled out the slide lift holes. I had a chance to ride it on hwy and it bogs down when I try to go over 75 mph. Anything I should check? Is this how it runs with jet kit? Thanks. Sent from Motorcycle.com Free App
  4. Technical
    I'm not sure but it seems my little ninja has lost some power. It takes longer to rev it up through the gears. I'll take it to 6krpm in 1st, then 8k after the following gears by ear and when upshifting it would start at 7k usually. The time between 7k --> 8k has gotten significantly longer...
  5. Technical
    OK Here goes... Rode the bike hard in the rain for about 400 miles with several stops. Parked outside under cover, same place as usual. Three days later (all rainy) went to start and had a nearly flat battery and no ignition. I put the battery on the trickle charger for about an hour. Battery...
1-5 of 5 Results
Top