Kawasaki Ninja 250R Forum - Reply to Topic
Thread: Gas meter Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Ninja 250R Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-21-2012 07:18 PM
DaBlue1 The fuel gauge and float is very rudimentary. It is possible that it's stuck. You can try to fix it yourself or just replace it. Either way you will have to drain the tank and remove the gauge from the bottom of the tank. The cost to replace the gauge is about $58. http://www.cheapcycleparts.com/model...semblies/25757
03-21-2012 01:36 PM
Ozzy250
Gas meter

hi i have a ninja250 2011. my gas meter isnt working. i know its not the arrow because when its off its all the way down. when i turn it off it goes all the way up. it doesnt tell me how much gas i have it always says its full. i dropped my bike once but that happen a month and a half before this problem came up. i did how ever tilt my bike to the side on top of the foot stand to turn my bike around. next day i noticed the problem. i haved asked around what seemed to be the problem, and by what i have learned its a sensor floating inside my gas tank. i wanna know how to change that, and also if im going to have to change the whole gas pump. thanks.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome