Engine doesn't start but turns over - Kawasaki Ninja 250R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-15-2020, 10:38 PM Thread Starter
Junior Member
 
Join Date: Jul 2020
Posts: 1
Unhappy Engine doesn't start but turns over

Hi,

I was driving to work as usual and passed a car while going downhill, carried on engine braking down the rest of the hill then when I came to the flat, there was no acceleration from the throttle. Engine was running fine but no response from the throttle. I pulled over and tried troubleshooting, turned the engine off and then it wouldn't start because I had no throttle. I have a 250R 2012 and it has no choke (EU). Been running perfectly fine the past couple weeks since the end of lockdown.

My first thought was a snapped throttle cable as it was after a quick acceleration passed the car, but it isn't and turns the carb spring fine.

Any help is appreciated, if you need any more information I'll try my best to provide. Thanks
ayjayes is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
engine, start, turns

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 250R Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome