Tachometer stopped working - Kawasaki Ninja 250R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-25-2015, 07:24 PM Thread Starter
Junior Member
 
MR_TOMMY's Avatar
 
Join Date: Aug 2014
Location: Westland, Mi.
Posts: 4
Tachometer stopped working

[I] NEED A CDi CONTROLLER FOR MY Ninja 250 the factory module cost 468.00 and i heard aftermarket is better but i cant find anyone who sells them. my bike only has 600 miles on it and my tachometer just stop working and all posts lead me to replacing this controller.

Is this the primary cause for the tach to just stop i only put 200 miles on bike since Nov. when i bought it. . its a 2010 250 but was built on 10/09

Mr._Tommy
MR_TOMMY is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-27-2015, 05:34 AM
Senior Member
 
DaBlue1's Avatar
 
Join Date: Jul 2011
Location: NC
Posts: 478
A tach cab go bad, but it's rare. A more likely problem with the tach not working is a bad connection. A bad CDI would affect the performance of the bike as well as erratic readings on the tach.

You can find a aftermarket CDI @ http://sportisimotorsport.us/index.p...products_id=12.

However, before you purchase one and install it, read up on it and be prepared to do a few small performance upgrades to get the most benefit from it.

https://www.250r.net/forum/showthread...DTIS#post20833
DaBlue1 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
stopped, tachometer, working

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 250R Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome