09 ninja weird issues just started happening - Kawasaki Ninja 250R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-17-2014, 05:54 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: Virginia
Posts: 4
09 ninja weird issues just started happening

Have an 09 ninja 250 aout a month ago the bike was acting real funky. It would start up then after driving it for a few minutes it would die and then completely not start. I shook the bike to slosh the gas around and it magically would cut off. I drove it hard to a day and put new gas in it and it has been fine ever since. Now I was driving it the other day starts up fine drove it 6 miles ad then it just completely died on me wouldn't start just crank. I had it towed home and now im trying to get it running it just cranks, ill shake the tank hard and then it will stay running 2-5 seconds and die down. Also fuel needle isn't moving when key is cycled. I really need some help getting her back right again. where should i start and what would most likely be the culprit. willing to try to do it al myself but experience is very limited with bikes and such
Vbninja is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-17-2014, 05:55 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: Virginia
Posts: 4
more info

also this bike has not been covered im wondering if with the hard rainstorms if its somehoe getting in the tank i have never had any problems until now.
Vbninja is offline  
post #3 of 7 (permalink) Old 09-18-2014, 02:10 AM
Senior Member
 
Join Date: Apr 2014
Location: Calgary,Alberta,Canada
Posts: 126
Almost sounds like you have debris/sediment in your gas tank that wants to settle around the fuel valve/petcock. First have a look inside the gas tank. Does it look like bare metal? Or does it look like it has scale on it like the inside of a tea kettle? Or maybe rusty? Or moisture/condensation? If you think moisture is a problem then buy some methyl hydrate and add say 3-5 oz. to your gas and see if that does anything first. It helps get rid of moisture in the fuel system. We use it in the winter up here to help get rid of condensation that builds up in gas tanks. Be careful with this next step, no smoking etc. Do it in a well vented area, due to gas fumes. detach the fuel valve hose from the carb. Have a rag in there to catch the spills. Leave the fuel valve In the on position.(it won't drain in the on position). To drain you turn it to the "Pri" position. Hook up some kind of extension hose and see if it will drain out into a gas can. Remove tank from bike. Then take the screws out for the fuel valve and gently remove the fuel valve/petcock. Being aware that gas can still be in there, have rags etc. Have a good look around the hole and see what kind of crud is in your tank? Flush it out into a tray or pail to see what you get? Try the methyl hydrate first though. If you have an inline fuel filter that is in between the fuel valve and the carbs then change that and evaluate be fore you drain the tank etc.
TurtleSE is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 09-18-2014, 05:15 AM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: Virginia
Posts: 4
thank you

awesome just needed some good starting points i'm going to try this and see where it takes me. thank you for the help.
Vbninja is offline  
post #5 of 7 (permalink) Old 09-19-2014, 06:32 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: Virginia
Posts: 4
Alright so i charged the battery up good and the bike will crank up and stay at idle now every now and then I will have to start rocking it back and forth or it will stall. I can also rev up to about 4k rpms as soon as I get on and give throttle it instantly does down. The thing that's really sending me for a loop right now is the fuel gauge is not moving or registering at all. Could this be causing my issues or is It just a coincidence. I will pull the tank tomorrow after work but any help I can definitely use and I will appreciate
Vbninja is offline  
post #6 of 7 (permalink) Old 09-19-2014, 06:50 PM
Senior Member
 
Ghostt's Avatar
 
Join Date: May 2014
Location: Summer Shade, Ky
Posts: 419
Garage
Might want to check the petcock, make sure it's working properly, and disassemble and clean it while you have the tank off, and do you have a fuel filter on the bike?, also, check all the vacuum lines, and remember to take your time and be meticulous.

A.T.G.A.T.T so I may ride another day. www.rockthegear.org

ZX-2R Photo gallery


I'm not your mom and I'm not paying for your parts, so do whatever you want with your own bike.
Ghostt is offline  
post #7 of 7 (permalink) Old 09-19-2014, 10:35 PM
Senior Member
 
Join Date: Apr 2014
Location: Calgary,Alberta,Canada
Posts: 126
I would first check fuses for fuel gauge. I don't think this is your primary problem though. If it was your bike wouldn't start at all. Then wiggle any connections from fuse box to fuel gauge and tank. See if it does any thing. After you finish with the tank and before you start it, you should drain the float bowls on the carbs. You need a 3mm hex bit. I also attach a tube to the drain on the carbs so I don't get gas every where. Leave the valve in the "on" position while draining. Close drain screws. Then before you start it turn the valve to "pri" for a bit. This will refill your carbs. Then turn it back to the "on" then start it when your ready. Watch what is draining out of the float bowls. Here's a pic of the bottom of the float bowls.
Attached Images
File Type: jpg image.jpg (121.1 KB, 6 views)
TurtleSE is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
happening, issues, ninja, started, weird

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 250R Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome