Help!!!!! Please!!! - Kawasaki Ninja 250R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-30-2012, 04:01 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Location: mi
Posts: 1
Help!!!!! Please!!!

My friend has a 07 ninja 250, and last summer it was running great and then it started running like crap. Once he hits 80 mph his bike loses power and wont go any faster. What could be wrong?

Carbs have been professionally cleaned along with the valves being adjusted. Gas tank has been cleaned, airbox is cleaned, new spark plugs and coils. Compression test was fine.

Also the right cylinder doesnt get warm and theres not exhaust smoke coming from right side muffler.
djisbamf is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-14-2012, 02:52 PM
Junior Member
 
Join Date: Apr 2012
Location: Connersville, IN USA
Posts: 14
I'm going to take a shot at this because my 2003 ninja was doing the same thing and it took my dealer a few attempts to find the problem. He eventually found the float needles we're not doing thier job. They are supposed to compress and mine wasn't. That helped but still didn't fix it, he then found that both main jets both had some build up and the holes were to small and it wasn't getting the gas it needed. Hope that helps, I'm not a mechanic, but mine did the exact same thing, only mine wouldn't go past 55. Runs like a dream now.
everett71 is offline  
post #3 of 5 (permalink) Old 04-14-2012, 03:09 PM
Junior Member
 
TheFranchise216's Avatar
 
Join Date: Mar 2012
Location: Florida
Posts: 1
Quote:
Originally Posted by everett71 View Post
I'm going to take a shot at this because my 2003 ninja was doing the same thing and it took my dealer a few attempts to find the problem. He eventually found the float needles we're not doing thier job. They are supposed to compress and mine wasn't. That helped but still didn't fix it, he then found that both main jets both had some build up and the holes were to small and it wasn't getting the gas it needed. Hope that helps, I'm not a mechanic, but mine did the exact same thing, only mine wouldn't go past 55. Runs like a dream now.
Mine seems to be doing that too. I have an 05. It just dies out at around 50 or so when I start slowing down. So is the fix to take the carbs apart, and clean out all jets? I'm a noob so sorry for the possible dumb question.
TheFranchise216 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-14-2012, 03:43 PM
Junior Member
 
Join Date: Apr 2012
Location: Connersville, IN USA
Posts: 14
I'm not sure about the details cuz I didn't do the work. They replaced the jets and the float needles, but I think replacing the main jets was the main culprit.
everett71 is offline  
post #5 of 5 (permalink) Old 04-16-2012, 08:39 AM
Senior Member
 
DaBlue1's Avatar
 
Join Date: Jul 2011
Location: NC
Posts: 478
Sounds like the carbs need synching.
DaBlue1 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
250, kawasaki, kawasaki ninja 250r, ninja

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 250R Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome