[2008+] Electrical Issue(s)? - Kawasaki Ninja 250R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-27-2017, 05:40 AM Thread Starter
Junior Member
 
Join Date: Oct 2017
Posts: 1
Electrical Issue(s)?

Hey guys, my girlfriend has an '11 Ninja 250 and is having problems with the electrical system.. It starts with the turn signals, the right turn signal works and blinks correctly, but the left turn signal just stays on without blinking, new bulbs and all. I talked to a mechanic friend and he suggested to try a new turn signal relay. Bought it and didn't see any difference.

Additionally, the bike seems temperamental when turning on and off. I'll try to start it, and if it doesn't start, it'll die and turning it on and off (with the key) will yield nothing.. the bike will literally be dead. Then all of a sudden (at random), when I turn the bike back on with the key it'll light back up like nothing happened and start.

Any thoughts, or if this is an entire electrical system issue?
rcarson15 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 250R Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome