Speedo Broken on NEW 2012 Ninja at 26 miles - Kawasaki Ninja 250R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-03-2013, 05:27 AM Thread Starter
Junior Member
 
frankhenderson1's Avatar
 
Join Date: Mar 2013
Location: South Florida
Posts: 4
Speedo Broken on NEW 2012 Ninja at 26 miles

I bought my NEW 2012 Ninja last Saturday and 4 days later, the speedometer breaks. Dealer was great. but GEEZ!
frankhenderson1 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-03-2013, 11:15 AM
Moderator
 
Mxslick's Avatar
 
Join Date: Feb 2013
Location: Idaho
Posts: 268
What was the part that failed? The actual speedo in the cluster, the cable or the drive unit on the front axle?

If it was the drive unit on the axle that is usually caused by the dealer's assembly person forcing it when assembling the front wheel of the bike.

If it was the cable that can be due to either a bad cable or one that was not lubed properly when it was made.

If it was the actual speedo that could be any number of things, but still mainly a defect.

I am betting one of two things was wrong: bad/damaged drive unit, or the cable wasn't tightened properly at the cluster end.

Also, did you notice anything odd before it failed? Twitching needle, low indicated speed, etc?
Mxslick is offline  
post #3 of 7 (permalink) Old 03-03-2013, 02:22 PM Thread Starter
Junior Member
 
frankhenderson1's Avatar
 
Join Date: Mar 2013
Location: South Florida
Posts: 4
It made a crunching sound and then stopped. I traded in a Harley for the Ninja.
frankhenderson1 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 03-03-2013, 03:39 PM
Senior Member
 
tadster00's Avatar
 
Join Date: Apr 2012
Location: Texas
Posts: 917
Mine's been messing up lately. I just bought a suction-cup phone mount, download a speedo app, and have been using my phone as my speedometer until I can get the thing fixed or replaced. Just an idea you may want to try if you have an android of an iphone, until you can also get it fixed
tadster00 is offline  
post #5 of 7 (permalink) Old 03-04-2013, 04:11 AM Thread Starter
Junior Member
 
frankhenderson1's Avatar
 
Join Date: Mar 2013
Location: South Florida
Posts: 4
Thanks - great idea!
frankhenderson1 is offline  
post #6 of 7 (permalink) Old 03-05-2013, 07:42 AM Thread Starter
Junior Member
 
frankhenderson1's Avatar
 
Join Date: Mar 2013
Location: South Florida
Posts: 4
The parts should be in today and they said come by. I am getting first service for free compliments of Kawasaki HDQ Irvine.
frankhenderson1 is offline  
post #7 of 7 (permalink) Old 03-05-2013, 06:10 PM
Moderator
 
Mxslick's Avatar
 
Join Date: Feb 2013
Location: Idaho
Posts: 268
Quote:
Originally Posted by frankhenderson1 View Post
The parts should be in today and they said come by. I am getting first service for free compliments of Kawasaki HDQ Irvine.
Good to hear that. Kawasaki is doing the right thing.

Yeah it sucks when a brand-new bike has problems, but with the mass production and just random bad luck sometimes defects get through. The real measure of the quality of a bike (or anything else) is how well the company responds to problems like this one.
Mxslick is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
2012, broken, miles, ninja, speedo

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 250R Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome